GA Release of Titanium SDK 7.0.1 & CLI 7.0.1

0 Flares 0 Flares ×

Today, we published General Availability releases of Axway Titanium SDK (includes Hyperloop) and Axway Appcelerator CLI (includes Alloy, API Builder, Cloud CLI, and Titanium CLI). This is a patch release addressing high priority issues from previous releases. It includes 3 improvements and 19 bug fixes. For a more detailed overview, known issues and closed tickets, see the release notes:

We’d like to thank the following community member who contributed to this release:
Richard Lustemberg for TIMOB-25576 – Ensuring usage of macros bundled core utilities and shells when adding to iOS buildPhases

Update Titanium SDK

Studio users will be prompted to update the SDK.

To update the Titanium SDK from the command line:

[appc] ti sdk install latest

Update Axway Appcelerator CLI

Studio users will be prompted to update the CLI.

To update the CLI from the command line:

[sudo] npm install -g appcelerator
appc use latest

Report bugs

If you run into any issues that seem related to the updates, please report them on JIRA.

First, check if it’s a known issue you can watch. If you can’t find an existing ticket, then create one in the Appcelerator Community (AC) project and add as much relevant information as you can, including the release version you are using.

You can leave general comments as a reply to this blog post.

0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×

2 Comments

  1. Arbind Bhagat

    I now get this error for android:
    [ERROR] : TiExceptionHandler: (main) [267,267] —– Titanium Javascript Runtime Error —–
    [ERROR] : TiExceptionHandler: (main) [0,267] – In ti:/module.js:303,2
    [ERROR] : TiExceptionHandler: (main) [0,267] – Message: Uncaught Error: Requested module not found: ti.cloudpush
    [ERROR] : TiExceptionHandler: (main) [0,267] – Source: throw new Error(‘Requested module not found: ‘ + request); // TODO Set ‘code’ property to ‘MODULE_NOT_FOUND’ to match Node?
    [ERROR] : V8Exception: Exception occurred at ti:/module.js:303: Uncaught Error: Requested module not found: ti.cloudpush

    • Arbind Bhagat

      Nevermind. I had to re-insert cloudpush module, and it is working great now. So, no issues.

Comments are closed.

Sign up for our blog!

computer and tablet showing Appcelerator software
Start free, grow from there.
0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×