Axway Appcelerator Blog

The Leading Resource for All Things Mobile

GA Release for Axway Appcelerator Studio 4.9.0 & Hyperloop 2.1.1

12 Flares 12 Flares ×

Today, we published General Availability (GA) releases as follows:

  • Axway Appcelerator Studio 4.9.0 is a minor release that includes new features, improvements and bug fixes
  • Hyperloop 2.1.1 is a patch release that includes several bug fixes

Release Notes

This release includes 50 bug fixes, 19 improvements, and 2 new features. For a more detailed overview, known issues, and closed tickets, see the release notes:

Update Axway Appcelerator Studio

To update Studio, launch Studio and open the “Help” menu. Select the “Check for Appcelerator Updates” item. You will be prompted to install the Studio update.

Update Hyperloop

To update Hyperloop using Appcelerator Studio, launch Studio and open the “Help” menu. Select the “Check for Appcelerator Updates” item. You will be prompted to install the Hyperloop update.

To update Hyperloop using CLI, please ensure you have selected a SDK of 6.0.0 or greater, then simply create a new project, respond “yes” when prompted to enable Hyperloop, and version 2.1.1 will be downloaded. To check which SDK you have selected from the CLI use:

[appc] ti sdk select

Report bugs

If you run into any issues that seem related to the updates, please report them on JIRA.

First, check if it’s a known issue you can watch. If you can’t find an existing ticket, then create one in the Appcelerator Community (AC) project and add as much relevant information as you can, including the release version you are using.

You can leave general comments as a reply to this blog post.

12 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 12 Email -- 12 Flares ×

2 Comments

Leave a Reply

Your email address will not be published. Required fields are marked *

  1. Ian Wall

    I dread, absolutely dread, Appcelerator updates on Windows over the past 2-3 years, and my frustration now causes me to reply here in the hope that something changes. I can’t think of a single time where something didn’t go wrong with either a Studio or SDK update, on Windows. This time, an error in SDK 6.1.0.GA prevents Android builds (I found the fix in JIRA), and now, after a PC reboot, Studio 4.9.0.201705302345 just sits hanging on startup, and I’m dead in the water without, of course, an attempt at yet another ‘clean’ install in the hope that resolves the problem. More hours lost due to another update. This is not to mention constant issues with “disconnects” and “device not found” when building/rebuilding without touching the connected device or cable, usually resolved simply by clicking build again or restarting Studio. Conversely, running this stuff on a Mac in an EMULATOR, no apparent issues, ever. It is my guess that most of the dev/QA/release team live/exist on Macs and do cursory tests on Windows before releases. Please strengthen up your Windows release cycle testing.

    • Erin Bailey

      Hi Ian – appreciate the feedback. Sorry you have had such troubles. I’ve passed on your comments to our product team.

Sign up for our blog!

Become a mobile leader. Take the first step to scale mobile innovation throughout your enterprise.
Get in touch
computer and tablet showing Appcelerator software
Start free, grow from there.
12 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 12 Email -- 12 Flares ×