Appcelerator Blog

The Leading Resource for All Things Mobile

Recent Facebook Developer Alert

1 Flares 1 Flares ×

Over the last day, several developers (not just those using Titanium) received an E-Mail from Facebook about the end of the deprecation-phase for Facebook Graph 2.0 and earlier:

[APP NAME] has been making recent API calls to Graph API v2.0, which will reach the end of the 2-year deprecation window on Monday, August 8, 2016. Please migrate all calls to v2.1 or higher in order to avoid potential broken experiences.

We recommend using our new Graph API Upgrade Tool to see which of your calls are affected by this change as well as any replacement calls in newer versions. You can also use our change log to see the full list of changes.

Summarized, it means that your Facebook Graph requests may stop working after 08/08/2016 and you should upgrade your Graph calls before that deadline.

What do I need to do? There are two things to verify:

  1. Ensure that you use the latest version of ti.facebook. We updated the Facebook SDK immediately after it’s release 2 years ago, so most of your current Apps should already be covered and the old ones need may need an update. You can verify that by running any fb.requestWithGraphPath() method and verify the logs do not throw a warning.
  2. Ensure that your backend also uses the latest Facebook SDK (PHP)

And that’s it! If you have further questions about the migration, check out our TiSlack or ask a question on StackOverflow.

Code strong! 🚀

1 Flares Twitter 0 Facebook 0 Google+ 1 LinkedIn 0 Email -- 1 Flares ×

Sign up for updates!

Become a mobile leader. Take the first step to scale mobile innovation throughout your enterprise.
Get in touch
computer and tablet showing Appcelerator software
Start free, grow from there.
1 Flares Twitter 0 Facebook 0 Google+ 1 LinkedIn 0 Email -- 1 Flares ×