Appcelerator Blog

The Leading Resource for All Things Mobile

Xcode 6.3 and iOS SDK 8.3 compatibility

0 Flares 0 Flares ×

Last week on April 8 Apple released Xcode 6.3 including the SDK for iOS 8.3. We have tested the current versions of Titanium Studio and Appcelerator Studio as well as our CLIs and current SDK for these new versions and found no problems. The same is true for the beta versions of the upcoming 4.0 GA.

If you do run into a problem you believe is caused by an incompatibility issue, please create a ticket on JIRA including as much specifics about the error as you can.

The previous release of Xcode and iOS included WatchKit, which we have phase 1 support for in beta. We will have a detailed guide ready at GA.

0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×

4 Comments

  1. jay

    After updating my iPad to 8.3 from 7.1.1, my app stopped working. My app is using urbenimage library. My app and Titanium Studio doesn’t show any error (with red background) nor showing any logs in Titanium Studio…. Please help me out …as i am almost at deployment/release stage. Please help me.

    • Fokke Zandbergen

      @jay could you create a topic at community.appcelerator.com and include example code so we and others can help you out to fix this problem?

  2. I was never able to connect Appcelerator 4 or Titanium 3.4 with XCode 6.3.2, even using the sudo xcode-select command. I assume that you was using Xcode 6.3, but are newer version tested? When trying to run a simulation, the applications(Appc/Ti) where not able because they could not find iOS 8.1. I hope Appcelerator soon will be compatible with the current version of Xcode, but I don´t find it is right now. There should be a compatibility list at appcelerator.com

    • Fokke Zandbergen

      @Age We’re about to announce compatibility with Xcode 6.4, but we haven’t seen problems with Xcode 6.3.x either. You say it’s looking for iOS 8.1 but Xcode 6.3 only comes with iOS 8.3 simulators by default. Are you sure you haven’t pre-selected that old iOS version somewhere?

      Please create a topic at community.appcelerator.com to further discuss this.

Comments are closed.

Sign up for updates!

Become a mobile leader. Take the first step to scale mobile innovation throughout your enterprise.
Get in touch
computer and tablet showing Appcelerator software
Start free, grow from there.
0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×