Appcelerator Blog

The Leading Resource for All Things Mobile

Announcing Node.js v0.10.22 support for Node.ACS applications

0 Flares 0 Flares ×

We are pleased to announce that we have upgraded our Node.ACS servers with Node.js v0.10.22 from v0.8.26. This version contains a fix for the “infamous Walmart memory leak”, an upgrade to the core uv library, and generally increased performance and stability.

To ease migration of Node applications to this new version, applications currently deployed on Node.ACS will continue to use v0.8.26 and function as before. If you republish your application to Node.ACS, you will get an error explaining that you should upgrade and test your application with 0.10.22, and republish it.

If you choose not to upgrade, and want to continue using 0.8.26, specify that version in the engines key of your project’s package.json file, and republish to ACS:

"engines": {
    "node": "0.8.26"
}

All newly published Node applications will run on v0.10.22, by default. As with existing applications, you can always “downgrade” your Node.js runtime environment to 0.8.26, if necessary.

To summarize: we strongly encourage you to upgrade and republish your application with v0.10.22 compatibility. If that’s not possible, you can continue to publish updates to your application by specifying the 0.8.26 runtime engine in the package.json file.

For more information, see the “Node.js Engine” section in Standard Node.js Applications.

0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×

Sign up for updates!

Become a mobile leader. Take the first step to scale mobile innovation throughout your enterprise.
Get in touch
computer and tablet showing Appcelerator software
Start free, grow from there.
0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×