Appcelerator Blog

The Leading Resource for All Things Mobile

3.2.0 RC of SDK/Studio Now Available

3 Flares 3 Flares ×

Following on the heels of the beta candidate of 3.2.0, we present our release candidate. 3.2.0 is a major update to our 3.1.0 version of the Titanium SDK and Titanium Studio. Version 3.2.0 brings numerous fixes and improvements across both products, as well as preliminary support for iOS 7.1 and Android 4.4. Today, we’re asking you to help test out the release and provide feedback before it becomes generally available in mid-December.

If you find an issue, please report it in JIRA with a reproducible test case. We ask you provide feedback on blocker issues by Monday, 12/16.

To update Studio, please visit and follow the instructions to update to the RC stream, or to download a new install.

Version 3.2.0 is special in that you need to update the SDK, the CLI and Studio. Studio and the CLI are both backwards compatible with previous versions of the SDK.

NPM Packages

Note: You may need to use ‘sudo’ before these terminal commands on OSX and Linux
npm install -g alloy@1.3.0-cr
npm install -g titanium@3.2.0-cr3
To revert back to stable versions:
npm remove -g titanium
npm install -g titanium
npm remove -g alloy
npm install -g alloy

Updates in Titanium 3.2.0

Read the complete Release Notes. A full list of updates is available here. 3.2.0 brings many new items:

  • Android 4.4 support
  • Animation improvements. There is a current regression for Animation which we are deferring to 3.2.1 as there is a workaround. Please take a look at TIMOB-15951 and leave comments there.
  • Cookie management
  • Android build command now rewritten in JavaScript with many, many bug fixes and improvements
  • ListView Phase 2 (Custom list and section headers and footers, custom row selection, dynamic item loading, search support)
  • xxhdpi support
  • In response to community feedback, we have changed the default behavior of application restarts (also known as Android bug 2373). We previously exposed a property named ‘’ to correct this behavior, but you needed to opt-in by setting a property in tiapp.xml. The setting is now on by default. See here for more information. This should be transparent (or better than before) to you and your users, but if you experience weird issues around app launching, please let us know.
  • Note: Android now builds with the latest Android API unless you have specified otherwise in your tiapp.xml
  • Attributed strings
  • Build directly to device (in Studio and CLI. For CLI, use ti build -p ios -T device -C <DEVICE_UDID> [-V “<DEVELOPER_CERTIFICATE_NAME>” -P <PROVISIONING_PROFILE_UUID>])
  • iOS 7.1 support (currently there is a blocker on simulator support: TIMOB-15741)
  • Dynamic animations
  • iOS 7 Animated transitions
  • iOS7 Background services
  • ListView Phase 2 (Custom list and section headers and footers, custom row selection, dynamic item loading, search support)
  • Brand new, much improved, platform installation and configuration wizard
  • Asynchronous login to speed up startup time
  • Auto-detection of connected devices with streamlined run/debug interface
  • Overhaul of user interface and switch to Eclipse 4.3 base
Deprecated items/Breaking changes
  • Android: FastDev support
  • Android: All windows are now heavyweight. Use <property name=”” type=”bool”>true</property> to return to the previous behavior
  • iOS: iOS 5 support and NavigationGroup
  • iOS: Map is now a separate module with new functionality
  • JSS support

Known Issues

Full list here.
  • There are currently issues running apps in the iOS 7.1 simulator. Please watch TIMOB-15741 for updates.
3 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 3 Email -- 3 Flares ×


  1. Nadav Hoze

    I updated SDK via update site and now my studio fails to launch.
    I’m using windows.

    I get the following message:

    An error has occurred see log file:
    C:\Users\Hoze\AppData\Local\Titanium Studio\Configuration\138695778559.log.

    The log says:
    !SESSION 2013-12-13 22:16:18.454 ———————————————–
    java.vendor=Oracle Corporation
    BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
    Framework arguments: -application com.aptana.commandline.launcher.LauncherApplication
    Command-line arguments: -os win32 -ws win32 -arch x86 -application com.aptana.commandline.launcher.LauncherApplication

    !ENTRY org.eclipse.equinox.ds 4 0 2013-12-13 22:16:18.794
    !MESSAGE FrameworkEvent ERROR
    !STACK 0
    org.osgi.framework.BundleException: The bundle “org.eclipse.equinox.ds_1.4.101.v20130813-1853 [756]” could not be resolved. Reason: Missing Constraint: Import-Package: org.eclipse.equinox.internal.util.event; version=”1.0.0″
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(
    at org.eclipse.osgi.framework.eventmgr.EventManager$

    !ENTRY org.eclipse.osgi 2 0 2013-12-13 22:16:19.023
    !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-12-13 22:16:19.023
    !MESSAGE Bundle reference:file:plugins/org.eclipse.ltk.ui.refactoring_3.7.100.v20130605-1748.jar was not resolved.
    !SUBENTRY 2 org.eclipse.ltk.ui.refactoring 2 0 2013-12-13 22:16:19.023
    !MESSAGE Missing required bundle org.eclipse.jface.text_[3.5.0,4.0.0).
    !SUBENTRY 1 org.eclipse.osgi 2 0 2013-12-13 22:16:19.023
    !MESSAGE Bundle reference:file:plugins/org.eclipse.equinox.p2.director.app_1.0.300.v20130819-1621.jar was not resolved.
    !SUBENTRY 2 2 0 2013-12-13 22:16:19.023
    !MESSAGE Missing required capability Require-Capability:; filter=”(|(&(”.

    • @Nadav One thing to try is to open “C:\Users\Hoze\AppData\Local\Titanium Studio\TitaniumStudio.ini” file and add “-clean” to the first line, and then launch Studio.

      If that doesn’t help, try moving the workspace (default at “C:\Users\Hoze\Documents\Titanium Studio Workspace”) to a different location and have Studio re-generate it when launching.

      Let me know if it helps.

      • Nadav Hoze

        Actually I downloaded the new version of Studio and now it works fine.
        But now my project fails to build.
        It says Error: No resource found that matches the given name (at ‘icon’ with value ‘@drawable/appicon’ event though I do not use appicon and my own icon in the tiapp.xml
        I changed the name to appicon and it works fine. but now the icons is titanium default.

  2. John Scanlon

    Well trying this out was a mistake.

    2 Major issues found in the first 5 minutes:
    Any changes to the tiapp.xml causes saved emulator/device configuration to reset to ‘Android Device’. When changing this back to ‘Android Emulator’ a new emulator is launched, even though one is still running. Things get screwed up, so you must wait for the new emulator to finish loaded, close the old emulator, run a ‘Project -> Clean’ then Run your project again.

    Denisty specific images no longer work. This is a deal breaker

    Guess this is what I get for being adventurous and wanting to try out some of the listview phase 2 features. Rolling everything back until this is stable.

    • Ingo Muschenetz

      @John, thank you for the report. For the second issue, is that We’re just fixing that now.

      • John Scanlon

        Yep, seems like these are the same issue.

        If you need more information on the first issue let me know what you want and I can document. I’ll probably not rollback to previous versions until tomorrow.

        • John Scanlon

          I lied, I couldn’t take the studio bug, so I tried to downgrade back to a stable version. Now, I can’t downgrade. I am doing ‘Help->Install New Software’ putting in “” as the workpath. Choosing the version of studio that is listed and i get an error saying i’m using a newer version. So it seems like there is no way to downgrade, unless I completely uninstall and reinstall. I hope this isn’t the case. Any advice is much appreciated.

        • Ingo Muschenetz

          TIMOB 16003 should fixed in the latest builds: See

          For the first issue, it sounds like ADB crashed. If you exit all emulators and kill ADB (adb kill-server on the command line), the CLI will start ADB automatically and everything should work. Can you perform the exact same set of steps to reproduce the issue? If so, can you please file JIRA ticket and we’ll look at immediately?

          If you want to roll back, you can follow!/guide/Reverting_to_a_Previous_Version-section-30083273_RevertingtoaPreviousVersion-RevertingtoaPreviousBuildofStudio, though honestly, the uninstall/reinstall of the installer should be quite painless. You can reuse the same workspace as before.

  3. Nadav Hoze

    shortcut for commenting code is not working on new studio.
    I press CTRL+/ but nothing happens.

  4. Nadav Hoze


    On android, adding to a tableview rows with pictures taken from camera shows only the the first image.

    I opened a ticket
    this is also correct for versions 3.1.1 – 3.1.3 (didn’t check on other earlier versions).

  5. jayesh

    i updated my machine with Titanium Alloy 1.3.0 and CLI 3.2.0 and SDK 3.2.0 but the previous projects i had created with SDK 3.1.1 GA are not working with this … specially for android all are heavyweight window and backward compatibility is gone…. not good.. :(

Comments are closed.

Sign up for updates!

Become a mobile leader. Take the first step to scale mobile innovation throughout your enterprise.
Get in touch
computer and tablet showing Appcelerator software
Start free, grow from there.
3 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 3 Email -- 3 Flares ×