Appcelerator Blog

The Leading Resource for All Things Mobile

Announcing Titanium 3.0.2

0 Flares 0 Flares ×

At Appcelerator we believe in continuous improvement and continuous innovation. We are pleased to announce the availability of Titanium 3.0.2.

This release includes support for iOS 6.1 and Xcode 4.6. It also includes support for iPhone5 Retina display images as well as the ability to provide a search widget on Android action bars.

Also included in this release is the GA version 1.0 of Appcelerator Alloy, our model-view-controller (MVC) framework. Alloy further accelerates the development of mobile apps by separating the UI from the business logic, and by enabling reusable widgets. Since we provided a pre-release version of Alloy in August  2012, it has been downloaded more than 60,000 times! We had feedback from more than 1,000 developers providing enhancement requests and bug reports. On average developers have reduced their native development time by over 35% using Alloy!

Appcelerator Alloy 1.0 is supported on Titanium 3.0 and later, and for those of you who have worked with 0.x versions of Alloy, we have put together a migration guide to help you move to Alloy 1.0. To get more info on Alloy, please visit:

As always, we would like to thank our more than 400,000-strong developer community for all of the support and feedback you provide us on a daily basis. Without this, Titanium would not be in the leadership position that it is in today. Please do keep the feedback and the apps coming. Our next planned release is Titanium 3.1, expected out later this year.

For further details on this release please read the release notes.

How to access Titanium 3.0.2:

For new users, download Titanium 3.0.2.

For existing Titanium Studio users, you will be prompted to update automatically on the next restart. You can also manually check for updates by selecting the “Check for Titanium SDK Updates” from the “Help” menu within Titanium Studio.

If you previously installed the Release Candidate versions of the Titanium CLI and Alloy, that is, npm install titanium@3.0.24-cr and npm install alloy@1.0.0-cr, you need to first uninstall these components before installing or updating to 3.0.2.GA. The release notes contain specific instructions on how to do so.  

0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×


  1. Ankit Thakur

    Hi Ingo,

    We are focusing on andvanced iOS 6.x SDK, but there are some of the great components available in iOS 4 onwards, which are still not in latest stable releases. One of them like UIMenuController. During Table views, this component is in a lot of use as per usability requirements.

  2. Michael

    Localization seems to be broken in 3.0.2 on Android devices. I’m using the L function and I’m getting mixed strings. iOS is still working fine and when I switch back to 3.0.0 its fine

  3. ads

    this bug is still present in this version

  4. Ingo Muschenetz

    @ads. Are the steps the same as before?

  5. Ingo Muschenetz

    @Michael…do you have a test case that demonstrates the problem?

  6. ads

    I didn’t used the code in the jira but the case is quite the same, the open event if in the window of my first tab, and the event is never fired..
    I think that this was back in 3.0 too (look at end of the jira)

  7. Umit

    Script Error = Couldn’t find module

  8. Michael

    After the update any event triggered by the .on method crashes our apps, anyone else with these issues?

    $.imageView.on(‘load’, saveImage);

    did work until the update today.

    same with:
    $.tableView.on(‘singletap’, goPageDetails);

  9. Ingo Muschenetz

    @Michael. Please file a bug and we can investigate.

  10. Jean-Sébastien GALLOO

    Hi, do you plan to integrate Google Maps Androïd API V2 (using SHA-1 fingerprint) for releasing Androïd App in production ? (as we need a key for production)

    Google Maps Androïd API V1 (using MD5 fingerprint) is deprecated next month (march 13th) and the way to generate the key using MD5 will not be possible anymore as written on their website:

    The Guide on your website wont be usable:

    It will become an issue for Ti project using maps…


  11. Ingo Muschenetz

    @Jean-Sébastien. Yes. We will be releasing a V2 version of a maps module shortly.

  12. Jean-Sébastien GALLOO

    Great, thanks !

    otherwise, for the moment, we can modify TiApp.xml as describe ?

  13. Umit

    Cant find a module i use, is it only me?

  14. Umit

    [ERROR] :  Script Error = Couldn’t find module: XXXXX

  15. Pedro

    [ERROR] :  Script Error = Couldn’t find module: ti.storekit

    whats happening? In 3.0.0 it woks flawlessly!

Comments are closed.

Sign up for updates!

Become a mobile leader. Take the first step to scale mobile innovation throughout your enterprise.
Get in touch
computer and tablet showing Appcelerator software
Start free, grow from there.
0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×