Appcelerator Blog

The Leading Resource for All Things Mobile

New release of Titanium (1.4.2) supports Apple’s new IOS SDK 4.2

0 Flares 0 Flares ×

Hello everyone,

I know a number of you have been curious about the recent news from Apple regarding the new IOS SDK 4.2, and how we will respond with Titanium Mobile.

The good news is that we have been working through some issues with IOS SDK 4.2, and preparing for a Titanium release today.

As you are reading this blog, we have released a Titanium Mobile 1.4.2 SDK which is IOS 4.2 compatible. Our 1.4.2 release is based on the former release, with just what is necessary to support IOS SDK 4.2. This release does not include the great work we’ve been doing in the past months toward our upcoming R1.5 release.

For those of you who need the latest code, and are pulling from our Git repository for IOS development, you will be happy to know that our “master branch” also supports IOS 4.2. We have been working hard to get ready for a Release 1.5 in the near future. Note that although there are many great fixes and improvements, we still have defects we need to address before we release Titanium 1.5.

So, feel free to download Apple’s IOS 4.2 and Titanium Mobile 1.4.2, and start creating awesome apps for this new IOS platform.

Code Strong!

Ralf Pfeiffer

Director of Platform Engineering

Appcelerator, Inc.

0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×


  1. Steve Perlow

    Glad to hear about this release, but a question – if we don’t update our apps using this new release will they not run on devices upgraded to iOS 4.2?

    I’m very hopeful the above isn’t the case, I’ve just seen some questions about the above that haven’t been answered.

    As always, thanks for all the hard work!

  2. rpfeiffer

    Some observations on our testing with IOS 4.2 GM:

    * non-updated Xcode (eg 4.1) , and Ti Dev (eg apps can still be built and pushed to a 4.2 device. (This was not true during Apple’s 4.2 beta which is one reason we made a new release)

    * Obviously using non updated tools you will not be able to use 4.2 features.

    * If you DO upgrade Xcode to 4.2, you need to upgrade TiDev to 1.4.2

  3. Skoua

    Thanks for this release, I was wondering today when would I be able to make a 4.2 version of my app, here’s my prompt answer. :)

    Just a silly question: if I install an app made with iOS 4.2 and Titanium 1.4.2 on a 4.1 iPhone without using any 4.2 feature, will it work?

    Thanks a lot for your great work, I was really amazed building my first app how easy it is with Titanium.

  4. Can i get a link to download 1.4.2?

  5. Skoua
  6. sj101

    Do we have to update our current apps in the appstore like we did when going from 3.1.3 to 4.0 iOS or will they work just fine without updating

  7. Robert

    same questions from me.
    i’m currently working with Titanium, XCode 3.2.4 and iOS SDK 4.1 and i want to submit my app to the app store within the next week.
    so i’m a little bit nervous about updating the XCode iOS SDK, updating Titanium and testing my app

    my questions:
    – do i have to update to Titanium 1.4.2 or can i go on with
    – do i have to update my iOS SDK to from 4.1 to 4.2 to submit my app?
    – my app currently runs on iPhone 3.1.3 and iPhone 4.1, will be 3.1.3 supported?

  8. Ralf PFeiffer

    Clarifications for the above replies:

    1) You do NOT have to update Apps in the App store to run on 4.2 devices

    2) You CAN use the older: Titanium, XCode 3.2.4 and iOS SDK 4.1 to distribute to the AppStore currently. And those should work same as the apps already in the store, even on 4.2 devices.

  9. Steve Perlow

    Thanks for the clarification Ralf, that’s great to hear.

    And thanks all for asking the good questions…

  10. Skoua

    Thanks for the reply.

  11. Jeremy

    I am a new user running OSX Snow Leopard. When I download the installer from the downloads page ( it gives me an installer for Titanium 1.2.1. Couldn’t figure out why Titanium wouldn’t start up the emulators until I discovered that 1.2.1 is an old version.

    You should probably update your download links to point to the newest version. Otherwise you’ll have a lot of people running into the same problems.

  12. Jeremy

    Is there an installer for OSX? I downloaded the zip file, but don’t know how to turn it into an application. Please provide the link to the Mac OSX installer for Titanium 1.4.2

  13. Hi there,

    Just need to understand the deployment method for this specific build. Should it be push via Ti Developer? or is there a zipped folder to drop into ‘Titanium/mobilesdk/osx/’


  14. Mario

    I have installed the latest beta of iOS SDK 4.2 and Titanium 1.4.2 but it does not work at all. The iOS simulator starts my apps only if I select SDK 4.0 (with 4.1 oder 4.1 no app starts) and if I try to install an app on my iPhone, I get only an “Install error” :-(

  15. Ralf PFeiffer

    @Mario: Can you please report this issue you are having in our HelpDesk system. This is the best way for it to get reported properly and addressed quickly.

    @Chris, @Jeremy:. Ti Dev should have the new link in the upper right messaging area, and it can update itself.

    All: The Titanium Developer version is 1.2.1. The latest Titanium Mobile SDK version is 1.4.2.

    Please everyone, remember that this Titanium mobile version 1.4.2 is based on the older (and just adds some enhancements for IOS 4.2). Ti mobile SDK 1.4.2 is NOT based on the latest code which developers can pull from Git master. The Git master branch is also IOS 4.2 ready.

    I hope this helps,

Comments are closed.

Sign up for updates!

Become a mobile leader. Take the first step to scale mobile innovation throughout your enterprise.
Get in touch
computer and tablet showing Appcelerator software
Start free, grow from there.
0 Flares Twitter 0 Facebook 0 Google+ 0 LinkedIn 0 Email -- 0 Flares ×