Appcelerator Blog

The Leading Resource for All Things Mobile

Introducing Titanium Desktop SDK 1.2 Release Candidate 4

1 Flares 1 Flares ×

Titanium Desktop SDK 1.2 Release Candidate 1 is now available, providing developers with the ability to create Titanium-based apps for distribution through Apple’s Mac App Store. A guide for the Mac App Store submission can be found here.

Additional features in the release include: * JavaScript source code minification and obfuscation through use of Google Closure Tools. * Support for the latest WebKit software on Mac OS and Linux, providing a consistent user experience across desktop deployment platforms. * Quality improvements and bug fixes across Linux, Mac OS and Windows.

Read the Release Notes for details on all new features and improvements.

Download and Installation

Download Links for Titanium Desktop SDK 1.2.0 Release Candidate 1: * Windows * Mac OS X * Linux 32-bit * Linux 64-bit

You may download the related API Documentation here.

To install, you’ll want to download the appropriate distribution above and then extract into your Titanium directory.

For example, on OSX, your Titanium directory will be under either /Library/Application Support/Titanium or~/Library/Appcelerator Support/Titanium..

On Linux ~/.titanium.

On Windows Vista/7 C:ProgramDataTitanium and on Windows XP C:Documents and SettingsAll UsersApplication DataTitanium

Once you locate your Titanium directory, extract the zip file into this directory. The zip file will expand the contents and create/overlay some new directories for 1.2.0-RC1.

NOTE for OSX users who use Safari to download: Safari by default will auto uncompress your downloads, how handy. However, if you have a directory named desktopsdk, your extracted directory will be renamed.

Now, you’ll need to restart Titanium Developer to pick up the new release. Once restarted, remember to change your application SDK version and then click the ‘Save’ button.

You should now be able to test with the release candidate software.

1 Flares Twitter 0 Facebook 1 Google+ 0 LinkedIn 0 Email -- 1 Flares ×


  1. Rob

    Thanks a lot. It even works on Ubuntu 11.04 now. Well done, guys.

  2. Just installed this RC and it has made my app far more stable as it was crashing every time after using an HTTPClient.

    Nice one.

  3. Ben

    Hm, I followed the instructions for OSX, but all I get is this when my app starts (followed by an installer dialog that doesn’t work):

    Unresolved: runtime 1.2.0.RC4
    Unresolved: tiapp 1.2.0.RC4
    Unresolved: tifilesystem 1.2.0.RC4
    Unresolved: tiplatform 1.2.0.RC4
    Unresolved: tiui 1.2.0.RC4
    Unresolved: ticodec 1.2.0.RC4
    Unresolved: tidatabase 1.2.0.RC4
    Unresolved: timedia 1.2.0.RC4
    Unresolved: timonkey 1.2.0.RC4
    Unresolved: tinetwork 1.2.0.RC4
    Unresolved: tiprocess 1.2.0.RC4
    Unresolved: tiworker 1.2.0.RC4

    All the new SDK files are right where they should be (at least, the same pattern that the 1.1.0 files are in).

    • Kevin Whinnery

      @Ben I think that particular error refers to the runtime – Titanium apps, on first run, deploy SDK files to either ~/Library or /Library/Application Support/Titanium/runtime/osx – there are directories for each of the Titanium Desktop runtimes installed, labeled by version number. In one of these directories, there should be a “1.2.0.RC4” directory. If that does not exist, you should run your application and allow that “installer dialog that doesn’t work” the chance to install these support files.

      If this doesn’t resolve your problem, please open up an issue in the Q&A and we can chase it down there instead of in the comments. Thanks!

  4. Ben
  5. Perfect install on Linux… but error with ruby support under linux.. while i try to test features between two platforms linux ubuntu 10.04 and Windows 7. I found that all runs ok on windows but not on linux,… ruby part isn’t working ok…

  6. Jef

    Does not work on Ubuntu 11.10 x64 :

    When launching Desktop App from Studio : “error while loading shared libraries: cannot open shared object file: No such file or directory”

  7. Jef

    I’ve been able to fix the problem on Ubuntu 11.10 : add natty/main repository, then apt-get both libffi5 and libnotify1 libraries.

  8. Cool works in Ubuntu 11.10 finally! I have working my applications in my new Ubuntu :)

    I have needed this:

    # ln -s /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/
    # ln -s /usr/lib/i386-linux-gnu/ /usr/lib/i386-linux-gnu/

Comments are closed.

Sign up for updates!

Become a mobile leader. Take the first step to scale mobile innovation throughout your enterprise.
Get in touch
computer and tablet showing Appcelerator software
Start free, grow from there.
1 Flares Twitter 0 Facebook 1 Google+ 0 LinkedIn 0 Email -- 1 Flares ×